NetBeans on Ubuntu

Oct 11, 2011  

I’ve been using NetBeans 6.9.1 which was the latest PHP version that I’d found, but also found that it wasn’t automatically updating.  I also tried using the standard package install, but had the same issues (a reported proxy error).  It turns out that the error is related to the version of Java SDK that NetBeans is using, and OpenSDK is what it was using.

You can get the latest version here:

http://www.oracle.com/technetwork/java/javase/downloads/jdk-7-netbeans-download-432126.html

After downloading, right-click the file and add execute permissions to it, and run it from the command prompt.  You can install the PHP plugins when it’s installed, and it checks for updates immediately.